策略路由实现双链路负载分担与冗余(实验成功)

前面发过一篇实验失败的记录,那次实验是在模拟器上采用PPPOE拔号的方式模拟双链路,因模拟器版本不支持Dialer 与NQA探测联动,具体内容可以查看我第一个记录文章。

这次实验默认路由的出接口是固定IP形式,路由器中生成了下一跳IP地址的ARP表项,满足了流行为中重定向IP的条件(重定向IP地址需设备中有对应的ARP表项,重定向才会生效)。

实验TOP图

用户侧交换机配置

#

sysname HuaweiSW

#

undo info-center enable

#

vlan batch 100 to 101 104

dhcp enable

#

ip pool vlan100

gateway-list 192.168.100.1

network 192.168.100.0 mask 255.255.255.0

#

ip pool vlan101

gateway-list 192.168.101.1

network 192.168.101.0 mask 255.255.255.0

#

interface Vlanif100

ip address 192.168.100.1 255.255.255.0

dhcp select global

#

interface Vlanif101

ip address 192.168.101.1 255.255.255.0

dhcp select global

#

interface Vlanif104

ip address 192.168.104.2 255.255.255.0

#

interface GigabitEthernet0/0/1

port link-type trunk

port trunk allow-pass vlan 104

#

interface GigabitEthernet0/0/3 //连接用户侧电脑

port hybrid pvid vlan 100

port hybrid untagged vlan 100

#

interface GigabitEthernet0/0/4 //连接用户电脑

port hybrid pvid vlan 101

port hybrid untagged vlan 101

#

ip route-static 0.0.0.0 0.0.0.0 192.168.104.1 //104.1 为出口路由器VLNAIF104 的地址

出口路由器配置

vlan batch 104

#

nqa test-instance admin link01 //NQA测试名称link01

test-type icmp

destination-address ipv4 192.168.25.1

frequency 60

start now

nqa test-instance admin link02 //NQA测试名称link02

test-type icmp

destination-address ipv4 192.168.26.1

frequency 60

start now

#

acl number 3001

rule 5 permit ip source 192.168.100.0 0.0.0.255 //匹配用户侧VLAN100的IP地址

acl number 3002

rule 5 permit ip source 192.168.101.0 0.0.0.255 //匹配用户侧VLAN101的IP地址

acl number 3003

rule 5 permit ip destination 192.168.104.1 0.0.0.0 //这个地址是路由器VLANIF104

匹配这个地址,主要是用户侧目的IP是这个地址时不进行策略路由,直接放行,

不然用户侧终端会访问不了192.168.104.1。

acl number 3004

rule 5 permit ip source 192.168.100.0 0.0.1.255 //用于NAT 匹配

#

traffic classifier link01 operator or

if-match acl 3001 //流分类匹配用户侧192.168.100.0

traffic classifier 104 operator or

if-match acl 3003 //流分类匹配路由器本身VLANIF104地址

traffic classifier link02 operator or

if-match acl 3002 //流分类匹配用户侧192.168.101.0

#

traffic behavior link01 //流行为link01

redirect ip-nexthop 192.168.25.1 track nqa admin link01 // 重定向下一跳地址与NQA admin link02联动,即NQA探测目的地址失败时,这个重定向下一跳不生效,路由按路由表走。

traffic behavior 104 //流行为104 ,默认是允许

traffic behavior link02 // 流行为link02

redirect ip-nexthop 192.168.26.1 track nqa admin link02 //重定向下一跳地址与NQA admin link01联动。

#

traffic policy linkall //流策略linkall,流分类与流行为绑定

classifier 104 behavior 104 // 匹配 目的地址192.168.104.1 通过 ,注意这条流策略要放前面。

classifier link01 behavior link01 //匹配源地址192.168.100.0 路由重定向

classifier link02 behavior link02 //匹配源地址192.168.101.0 路由重定向

#

interface Vlanif104 //与用户侧交换机连通

ip address 192.168.104.1 255.255.255.0

#

interface Ethernet0/0/0 //连接用户侧交换机

port link-type trunk

port trunk allow-pass vlan 104

traffic-policy linkall inbound //入口方向绑定流策略

#

interface GigabitEthernet0/0/0 //连接link01路由器

ip address 192.168.25.2 255.255.255.0

nat outbound 3004 //NAT 用户侧IP段

#

interface GigabitEthernet0/0/1 //连接link02路由器

ip address 192.168.26.2 255.255.255.0

nat outbound 3004 //NAT 用户侧IP段

#

interface NULL0

#

ip route-static 0.0.0.0 0.0.0.0 192.168.26.1 track nqa admin link02 //默认路由与NQA联动

ip route-static 0.0.0.0 0.0.0.0 192.168.25.1 track nqa admin link01 //默认路由与NQA联动

ip route-static 192.168.100.0 255.255.255.0 192.168.104.2 //回路由至用户侧交换机

ip route-static 192.168.101.0 255.255.255.0 192.168.104.2 //回路由至用户侧交换机

#

实验记录下个笔记中发。

路由器百科

小米路由器怎么登陆(如何进入小米路由器的登录界面)

2022-10-28 13:04:06

路由器百科

家用无线路由器的设置方法(家用无线路由器的设置方法图解)

2022-10-28 14:27:09

0 条回复 A文章作者 M管理员
    暂无讨论,说说你的看法吧
个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索