锐捷路由器固定IP上网配置(固定ip如何配置路由器)

固定IP上网配置:

用户使用电信的光纤线路接入Internet,用户将电信提供的光纤接头通过光纤转换器与路由器的WAN口连接。用户在WAN口上使用电信分配的广域网地址218.5.19.2,在LAN口上使用内部网地址192.168.0.1,该地址即内部网关地址。用户在LAN和WAN口上配置了NAT以使内部网用户可以共享光纤线路来访问Internet。

固定 IP地址接入典型配置示例

在这种情况下,就可以在NBR上如下配置即可:

Red-Giant>enable

!启动快速配置功能

Red-Giant#setup

———— 交互式系统配置 —————-

输入ctrl-c中止配置流程;默认配置参数在'[]’中。

!选择是否进入快速配置流程

确定进入交互式系统配置? [yes]: yes

配置全局参数:

请输入路由器名称(只能用字母数字组合) [Red-Giant]: NBR

!配置进入特权用户层的口令

请输入特权用户密码: private

!配置允许远程Telnet登陆的用户密码

请输入telnet远程登陆密码: remoteuser

!启动防止冲击波病毒的功能

启动防止冲击波病毒功能会降低性能,如果确认没有病毒,请不要启动!

是否启动此功能? [no]: yes

!选择广域网接入方式。这个示例中由于是通过电信的光纤接入,广域网使用的是电信分配的固定IP地址,故这里选择模式1

请选择上网模式:

1. 固定IP地址

2. PPPOE连接

3. DHCP分配IP

请输入数字1—3: 1

!这里为广域网接口FastEthernet 0设置电信分配的固定IP地址以及掩码。

配置广域网口FastEthernet0:

请输入IP地址: 218.5.19.2

请输入地址掩码 [255.255.255.0]:

!禁止广域网上其他用户ping广域网口以防止来自广域网上的Ping攻击。

是否允许ping广域网接口? [yes]: no

!配置本地局域网口FastEthernet 1的地址和掩码,这也是内部网关的地址

配置局域网口FastEthernet1:

请输入IP地址: 192.168.0.1

请输入地址掩码 [255.255.255.0]:

!配置广域网路由信息,这里设置的是广域网下一跳路由。

配置广域网缺省网关(下一跳IP地址):

请输入缺省网关IP地址:218.5.19.1

!内部网络的网络主机使用的是固定IP地址,因此无需为内部主机开启DHCP Server功能。

是否对内部局域网启用DHCP SERVER功能? [no]:

!至此,快速配置生成的配置教本预览

配置完毕,生成的配置脚本文件如下:

hostname NBR

ip routing

enable secret 5 $1$I3u0$.RIU6kH0S.fil.ivOe9td1

line vty 0 4

password remoteuser

!

!

interface FastEthernet0

no shutdown

ip address 218.5.19.2 255.255.255.0

ip access-group 100 in

ip nat outside

no ip unreachables

!

!

interface FastEthernet1

no shutdown

ip address 192.168.0.1 255.255.255.0

ip access-group 100 in

ip nat inside

!

access-list 100 deny icmp any any echo

access-list 100 deny icmp any any echo-reply

ip route 0.0.0.0 0.0.0.0 218.5.19.1

!

ip nat inside source list 1 interface FastEthernet 0 overload

ip nat optimize

!

access-list 1 permit any

access-list 100 deny tcp any any eq 135

access-list 100 deny tcp any any eq 136

access-list 100 deny tcp any any eq 137

access-list 100 deny tcp any any eq 138

access-list 100 deny tcp any any eq 139

access-list 100 deny tcp any any eq 445

access-list 100 deny udp any any eq 135

access-list 100 deny udp any any eq 136

access-list 100 deny udp any any eq netbiOS-ns

access-list 100 deny udp any any eq netbios-dgm

access-list 100 deny udp any any eq 139

access-list 100 deny udp any any eq 445

access-list 100 deny tcp any any eq 4444

access-list 100 deny udp any any eq tftp

access-list 100 deny icmp any any echo

access-list 100 deny icmp any any echo-reply

access-list 100 permit ip any any

!

end

!确定保存当前配置

是否应用此配置? [yes/no]: yes

Building configuration…

[OK]

在enabLED 模式下使用’configure’命令可修改这些配置。

NBR#

%UPDOWN: Line protocol on Interface FastEthernet0, changed state to up

%UPDOWN: Line protocol on Interface FastEthernet1, changed state to up

%CHANGED: Interface Dialer0, changed state to administratively down

%UPDOWN: Interface FastEthernet0, changed state to up

%UPDOWN: Interface FastEthernet1, changed state to up

!再次检查配置.

NBR#show running-config

Building configuration…

Current configuration:

!

!

hostname “NBR”

!

enable secret 5 $1$I3u0$.RIU6kH0S.fil.ivOe9td1

!

!

!

ip subnet-zero

!

interface FastEthernet0

ip address 218.5.19.2 255.255.255.0

ip access-group 100 in

no ip unreachables

ip nat outside

!

interface FastEthernet1

ip address 192.168.0.1 255.255.255.0

ip access-group 100 in

ip nat inside

!

ip nat inside source list 1 interface FastEthernet0 overload

ip nat optimize

ip classless

ip route 0.0.0.0 0.0.0.0 218.5.19.1

access-list 1 permit any

access-list 100 deny icmp any any echo

access-list 100 deny icmp any any echo-reply

access-list 100 deny tcp any any eq 135

access-list 100 deny tcp any any eq 136

access-list 100 deny tcp any any eq 137

access-list 100 deny tcp any any eq 138

access-list 100 deny tcp any any eq 139

access-list 100 deny tcp any any eq 445

access-list 100 deny udp any any eq 135

access-list 100 deny udp any any eq 136

access-list 100 deny udp any any eq netbios-ns

access-list 100 deny udp any any eq netbios-dgm

access-list 100 deny udp any any eq 139

access-list 100 deny udp any any eq 445

access-list 100 deny tcp any any eq 4444

access-list 100 deny udp any any eq tftp

access-list 100 permit ip any any

!

line con 0

line vty 0 4

password remoteuser

login

!

End

路由器百科

怎么用手机登陆水星路由器(怎样用手机设置水星无线路由器)

2022-10-30 19:07:08

路由器百科

路由器怎么摆(无线路由器应当如何摆放)

2022-10-30 20:26:13

0 条回复 A文章作者 M管理员
    暂无讨论,说说你的看法吧
个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索