华为,H3C和锐捷:一起学习如何配置SSH登录

华为

1.在服务器端生成本地密钥对。

system-view

sysname SSH Server

dsa local-key-pair create

2.在服务器端创建SSH用户。

#配置VTY用户界面。

user-interface vty 0 4

authentication-mode aaa

protocol inbound ssh

quit

#创建SSH用户client001,认证方式为password。

aaa

local-user client001 password irreversible-cipher Test@123

local-user client001 privilege level 3

local-user client001 service-type ssh

quit

ssh user client001

ssh user client001 authentication-type password

#创建SSH用户client002,认证方式为dsa。

ssh user client002

ssh user client002 authentication-type dsa

#在stelnet客户端client002生成客户端的本地密钥对。

system-view

sysname client 002

dsa local-key-pair create

#查看客户端上生成的DSA密钥对的公钥部分。

display dsa local-key-pair public

#将客户端上产生的DSA公钥配置到服务器端(上面display命令显示信息中黑体部分即为客户端产生的DSA公钥,将其拷贝粘贴至服务器端)。

dsa peer-public-key dsakey001 encoding-type der

public-key-code begin

30820109

02820100

CA97BCDE 697CEDE9 D9AB9475 9E004D15 C8B95116

87B79B0C 5698C582 69A9F4D0 45ED0E53 AF2EDEC1

A09DF4BE 459E34B6 6697B85D 2191A00E 92F3A5E7

0203

010001

public-key-code end

peer-pubilc-key end

#在SSH服务器端为SSH用户client002绑定stelent客户端的dsa公钥。

ssh user client002 assign dsa-key dsakey001

3.SSH服务器端开启stelent服务功能。

#开启stelent服务功能。

ssh server-source -I vlanif 5 //假设客户端使用IP地址10.1.1.1连接服务器,该地址对应的接口为vlanif 5。

stelnet server enable

4.配置SSH用户client001、client002的服务方式为stelnet。

ssh user client001 service-type stelnet

ssh user client002 service-type stelnet

5.Stelnet客户端连接SSH服务器。

#第一次登录,需要使能SSH客户端首次认证功能,使能客户端client001首次认证功能。

system-view

sysname client001

ssh client first-time enable

#使能客户端client002首次认证功能。

ssh client first-time enable

#stelnet客户端client001用password认证方式连接SSH服务器,输入配置的用户名和密码。

stelnet 10.1.1.1

#stelnet客户端client002用dsa认证方式连接SSH服务器。

stelnet 10.1.1.1 user-identity-key dsa

6.验证配置结果。

display ssh server status #查看SSH状态信息。

display ssh user-information #查看SSH用户信息。

H3C

1.配置Stelnet服务器。

#生成RSA密钥对。

system-view

public-key local create rsa

#生成DSA密钥对。

public-key local create dsa

#生成ECDSA密钥对。

public-key local create ecdsa secp256r1

#开启stelent服务器功能。

ssh server enable

#配置vlan接口2的IP地址,客户端将通过该地址连接stelent服务器。

interface vlan-interface 2

ip address 192.168.1.40 255.255.255.0

quit

#设置stelnet客户端登录用户线的认证方式为AAA认证。

line vty 0 63

authentication-mode scheme

quit

#创建设备管理类本地用户client001,并设置密码为明文h3c@123,服务器类型为SSH,用户角色为network-admin。

local-user client001 class manage

password simple h3c@123

service-type ssh

authorization-attribute user-role network-admin

quit

#配置SSH用户client001的服务器类型为stelent,认证方式为password认证。

ssh user client001 service-type stelnet authentication-type password

2.stelnet客户端建立与stelnet服务器的连接。

#配置vlan接口2的IP地址。

system-view

interface vlan-interface 2

ip address 192.168.1.56 255.255.255.0

quit

#建立到服务器192.168.1.40的SSH连接。

ssh2 192.168.1.40

锐捷

1.开启交换机的SSH服务功能。

configure terminal

enable service ssh-server

2.生成加密密钥。

crypto key generate dsa

3.配置交换机的管理IP地址。

inerface vlan 1

ip address 192.168.1.1 255.255.255.0

4.SSH登录时使用用户名及密码登录交换机。

line vty 04

login local

exit

username admin password ruijie

enable password ruijie

end

write

line vty 0 4

transport input ssh //只允许使用SSH登录。

#建立到服务器192.168.1.1的SSH连接

ssh2 192.168.1.1

5.验证配置。

show service //确认SSH服务功能是否开启。

show users //查看当前登入的用户。

路由器百科

快速设置幻灯片背景的三个小技巧(快速设置幻灯片背景的三个小技巧是什么)

2022-10-30 11:43:39

路由器百科

腾达路由器咋样(腾达无线路由器如何)

2022-10-30 12:39:38

0 条回复 A文章作者 M管理员
    暂无讨论,说说你的看法吧
个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索